aboutsummaryrefslogtreecommitdiff
path: root/dev-python/restrictedpython/restrictedpython-6.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-02-04 20:15:00 -0500
committerJulien Roy <julien@jroy.ca>2023-02-04 20:15:00 -0500
commit3c6bac98b48247b639ceec52209c92cd113034a0 (patch)
treedbbc47164ce968de9ed7546281ea43cf12b2cad5 /dev-python/restrictedpython/restrictedpython-6.0.ebuild
parent3d08ad7c1487d19e201dcb7c12c9af9f73b59628 (diff)
downloadMrRoy-Overlay-3c6bac98b48247b639ceec52209c92cd113034a0.tar.gz
MrRoy-Overlay-3c6bac98b48247b639ceec52209c92cd113034a0.tar.bz2
MrRoy-Overlay-3c6bac98b48247b639ceec52209c92cd113034a0.zip
dev-python/restrictedpython: new package, add 6.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/restrictedpython/restrictedpython-6.0.ebuild')
-rw-r--r--dev-python/restrictedpython/restrictedpython-6.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/restrictedpython/restrictedpython-6.0.ebuild b/dev-python/restrictedpython/restrictedpython-6.0.ebuild
new file mode 100644
index 0000000..e8d2e5d
--- /dev/null
+++ b/dev-python/restrictedpython/restrictedpython-6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A restricted execution environment for Python to run untrusted code"
+HOMEPAGE="https://github.com/zopefoundation/RestrictedPython"
+SRC_URI="https://github.com/zopefoundation/RestrictedPython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/RestrictedPython-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ doc? ( dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest