aboutsummaryrefslogtreecommitdiff
path: root/dev-python/persistent/persistent-5.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-01-03 19:26:16 -0500
committerJulien Roy <julien@jroy.ca>2024-01-03 19:26:16 -0500
commitfaada8d9a4c584f77e7a212b42c6845378d4b85a (patch)
treed2660410c8ddf14459d42f22b296dae091bbf853 /dev-python/persistent/persistent-5.1.ebuild
parent227cbd8bcc1b3693e1f57eba34c775d4a1eb1c0b (diff)
downloadMrRoy-Overlay-faada8d9a4c584f77e7a212b42c6845378d4b85a.tar.gz
MrRoy-Overlay-faada8d9a4c584f77e7a212b42c6845378d4b85a.tar.bz2
MrRoy-Overlay-faada8d9a4c584f77e7a212b42c6845378d4b85a.zip
dev-python/persistent: moved from ::guru
Diffstat (limited to 'dev-python/persistent/persistent-5.1.ebuild')
-rw-r--r--dev-python/persistent/persistent-5.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/persistent/persistent-5.1.ebuild b/dev-python/persistent/persistent-5.1.ebuild
new file mode 100644
index 0000000..1386517
--- /dev/null
+++ b/dev-python/persistent/persistent-5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="automatic persistence for Python objects"
+HOMEPAGE="https://github.com/zopefoundation/persistent"
+SRC_URI="https://github.com/zopefoundation/persistent/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ doc? ( dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_unpack() {
+ default
+ # Fix broken test
+ sed -i -e 's/from \.\./from persistent/' "${S}/src/persistent/tests/test_ring.py" || die
+ # Disable tests that fail
+ sed -z -i -e "s/def test__p_repr_exception.*_p_repr failed')>\")//g" \
+ "${S}/src/persistent/tests/test_persistence.py" || die
+ sed -z -i -e "s/def test__p_repr_in_instance_ignored.*repr(p)//g" \
+ "${S}/src/persistent/tests/test_persistence.py" || die
+}
+
+src_test() {
+ cd "${S}/src/persistent" || die
+ distutils-r1_src_test
+}