aboutsummaryrefslogtreecommitdiff
path: root/dev-python/persistent/persistent-5.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-01-03 18:50:06 -0500
committerJulien Roy <julien@jroy.ca>2024-01-03 18:50:06 -0500
commit2f51663d691559aae300b3d980847181446b907a (patch)
treeeaf43eeeb8356c4aac6364f89fd851e4bb66870c /dev-python/persistent/persistent-5.0.ebuild
parent4ceb54d490541b454a086bbba70820c0807db10d (diff)
downloadMrRoy-Overlay-2f51663d691559aae300b3d980847181446b907a.tar.gz
MrRoy-Overlay-2f51663d691559aae300b3d980847181446b907a.tar.bz2
MrRoy-Overlay-2f51663d691559aae300b3d980847181446b907a.zip
dev-python/persistent: treeclean
Diffstat (limited to 'dev-python/persistent/persistent-5.0.ebuild')
-rw-r--r--dev-python/persistent/persistent-5.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/persistent/persistent-5.0.ebuild b/dev-python/persistent/persistent-5.0.ebuild
deleted file mode 100644
index 6cd2ea8..0000000
--- a/dev-python/persistent/persistent-5.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="automatic persistence for Python objects"
-HOMEPAGE="https://github.com/zopefoundation/persistent"
-SRC_URI="https://github.com/zopefoundation/persistent/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/cffi[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- doc? ( dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}] )
- test? (
- dev-python/manuel[${PYTHON_USEDEP}]
- dev-python/zope-testrunner[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_sphinx docs
-distutils_enable_tests setup.py
-
-src_unpack() {
- default
- # # Fix broken test
- # sed -i -e 's/from \.\./from persistent/' "${S}/src/persistent/tests/test_ring.py" || die
- # # Disable tests that fail
- # sed -z -i -e "s/def test__p_repr_exception.*_p_repr failed')>\")//g" \
- # "${S}/src/persistent/tests/test_persistence.py" || die
- # sed -z -i -e "s/def test__p_repr_in_instance_ignored.*repr(p)//g" \
- # "${S}/src/persistent/tests/test_persistence.py" || die
-}
-
-python_compile_all() {
- # Create Zope Namespace
- mkdir -p "${BUILD_DIR}/install$(python_get_sitedir)/zope" || die
- echo "__path__ = __import__('pkgutil').extend_path(__path__, __name__)" > \
- "${BUILD_DIR}/install$(python_get_sitedir)/zope/__init__.py" || die
- build_sphinx docs
- rm "${BUILD_DIR}/install$(python_get_sitedir)/zope/__init__.py"
-}
-
-python_test() {
- zope-testrunner -pvc -j "$(nproc)" --usecompiled \
- --path "${BUILD_DIR}/install$(python_get_sitedir)/${PN}" || die
-}