aboutsummaryrefslogtreecommitdiff
path: root/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-15 15:40:33 -0400
committerJulien Roy <julien@jroy.ca>2024-05-15 15:40:33 -0400
commit622d467417294ea110808577543304a39cb7cc0e (patch)
tree5eea00b6a3108f8fcd9c7e1f1a853fbf926a7d30 /dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild
parent67fe63d3932bb4f914cfd4e82d218c847a72fc2a (diff)
downloadMrRoy-Overlay-622d467417294ea110808577543304a39cb7cc0e.tar.gz
MrRoy-Overlay-622d467417294ea110808577543304a39cb7cc0e.tar.bz2
MrRoy-Overlay-622d467417294ea110808577543304a39cb7cc0e.zip
dev-python/orderedmultidict: new package, add 1.0.1
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild')
-rw-r--r--dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild b/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild
new file mode 100644
index 0000000..7692a0a
--- /dev/null
+++ b/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Ordered Multivalue Dictionary. Helps power furl. "
+HOMEPAGE="https://github.com/gruns/orderedmultidict"
+SRC_URI="https://github.com/gruns/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="test? ( dev-python/flake8[${PYTHON_USEDEP}] )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest