aboutsummaryrefslogtreecommitdiff
path: root/dev-python/olm/olm-3.2.14.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-22 22:57:51 -0500
committerJulien Roy <julien@jroy.ca>2023-01-22 22:57:51 -0500
commit1e3e2506203331b90aa1ccbdf571c27b7ef3ad14 (patch)
tree3f3a6fb21cd9639446bfe383333b95eb983fcb2f /dev-python/olm/olm-3.2.14.ebuild
parentce7da04d2c2fb7de10f862fd60c97f6809a0f9ef (diff)
downloadMrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.tar.gz
MrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.tar.bz2
MrRoy-Overlay-1e3e2506203331b90aa1ccbdf571c27b7ef3ad14.zip
*/*: treeclean packages which are now in GURU
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/olm/olm-3.2.14.ebuild')
-rw-r--r--dev-python/olm/olm-3.2.14.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/olm/olm-3.2.14.ebuild b/dev-python/olm/olm-3.2.14.ebuild
deleted file mode 100644
index e8b469f..0000000
--- a/dev-python/olm/olm-3.2.14.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for dev-libs/olm"
-HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm/"
-SRC_URI="https://gitlab.matrix.org/matrix-org/olm/-/archive/${PV}/${P}.tar.bz2"
-S="${WORKDIR}/${P}/python"
-RESTRICT="!test? ( test )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-libs/olm
- dev-python/cffi[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- test? (
- dev-python/aspectlib[${PYTHON_USEDEP}]
- dev-python/pytest-benchmark[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-flake8[${PYTHON_USEDEP}]
- dev-python/pytest-isort[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-src_install() {
- distutils-r1_src_install
- # To avoid merge collision with dev-libs/olm
- rm "${ED}/usr/share/doc/${P}/README.md" || die
-}