aboutsummaryrefslogtreecommitdiff
path: root/dev-python/hachoir/hachoir-3.2.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-20 20:35:41 -0500
committerJulien Roy <julien@jroy.ca>2023-01-20 20:35:41 -0500
commit303a6948ed571563135c8921ee64a2d112615d87 (patch)
tree0ae016fa05f17da545cb1d68666ee7f6cf83527b /dev-python/hachoir/hachoir-3.2.0.ebuild
parent83c928e1e269e38b884ff26e7252279b1e48f6b1 (diff)
downloadMrRoy-Overlay-303a6948ed571563135c8921ee64a2d112615d87.tar.gz
MrRoy-Overlay-303a6948ed571563135c8921ee64a2d112615d87.tar.bz2
MrRoy-Overlay-303a6948ed571563135c8921ee64a2d112615d87.zip
dev-python/hachoir: new package, add 3.2.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/hachoir/hachoir-3.2.0.ebuild')
-rw-r--r--dev-python/hachoir/hachoir-3.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/hachoir/hachoir-3.2.0.ebuild b/dev-python/hachoir/hachoir-3.2.0.ebuild
new file mode 100644
index 0000000..e7e3320
--- /dev/null
+++ b/dev-python/hachoir/hachoir-3.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hachoir is a Python library to view and edit a binary stream field by field "
+HOMEPAGE="https://github.com/vstinner/hachoir/"
+SRC_URI="https://github.com/vstinner/hachoir/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}"
+
+
+distutils_enable_tests pytest