aboutsummaryrefslogtreecommitdiff
path: root/dev-python/furl/furl-2.1.2.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2022-12-22 20:28:43 -0500
committerJulien Roy <julien@jroy.ca>2022-12-22 20:28:43 -0500
commitd2eeaeb0441ddcdfbf350c6d4b4487e9d866124f (patch)
tree2d7c850ad759fd34646a612ec0e4c7a8945312cc /dev-python/furl/furl-2.1.2.ebuild
parentf1285c7187df0b8f330c1e8388da71ea766fa9d5 (diff)
downloadMrRoy-Overlay-d2eeaeb0441ddcdfbf350c6d4b4487e9d866124f.tar.gz
MrRoy-Overlay-d2eeaeb0441ddcdfbf350c6d4b4487e9d866124f.tar.bz2
MrRoy-Overlay-d2eeaeb0441ddcdfbf350c6d4b4487e9d866124f.zip
dev-python/furl: new package, add 2.1.2
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/furl/furl-2.1.2.ebuild')
-rw-r--r--dev-python/furl/furl-2.1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/furl/furl-2.1.2.ebuild b/dev-python/furl/furl-2.1.2.ebuild
new file mode 100644
index 0000000..be5ee7d
--- /dev/null
+++ b/dev-python/furl/furl-2.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="URL parsing and manipulation made easy."
+HOMEPAGE="https://github.com/gruns/furl"
+SRC_URI="https://github.com/gruns/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="test? ( dev-python/flake8[${PYTHON_USEDEP}] )
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/orderedmultidict[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest