aboutsummaryrefslogtreecommitdiff
path: root/dev-python/emailthreads/emailthreads-0.1.3.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-13 13:28:08 -0400
committerJulien Roy <julien@jroy.ca>2024-04-13 13:28:08 -0400
commite4c3436be518d11b38f943c73e03905d0bfb57b0 (patch)
treef788c76441033bffd2961115545231d8644a8ea0 /dev-python/emailthreads/emailthreads-0.1.3.ebuild
parentbf380e9c463774dc88db7969c39dd6b71ce6561e (diff)
downloadMrRoy-Overlay-e4c3436be518d11b38f943c73e03905d0bfb57b0.tar.gz
MrRoy-Overlay-e4c3436be518d11b38f943c73e03905d0bfb57b0.tar.bz2
MrRoy-Overlay-e4c3436be518d11b38f943c73e03905d0bfb57b0.zip
dev-python/emailthreads: new package, add 0.1.3
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/emailthreads/emailthreads-0.1.3.ebuild')
-rw-r--r--dev-python/emailthreads/emailthreads-0.1.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/emailthreads/emailthreads-0.1.3.ebuild b/dev-python/emailthreads/emailthreads-0.1.3.ebuild
new file mode 100644
index 0000000..4a02155
--- /dev/null
+++ b/dev-python/emailthreads/emailthreads-0.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Parses email threads into conversation trees"
+HOMEPAGE="https://github.com/emersion/python-emailthreads"
+SRC_URI="https://github.com/emersion/python-${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/python-${PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py