aboutsummaryrefslogtreecommitdiff
path: root/dev-python/emailthreads/emailthreads-0.1.3.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2022-12-23 13:35:06 -0500
committerJulien Roy <julien@jroy.ca>2022-12-23 13:35:06 -0500
commit672a43b6d8b0b8c30f224fc5895c87e0efec52bb (patch)
tree91608839781807ada3fe50161006565f92c0a669 /dev-python/emailthreads/emailthreads-0.1.3.ebuild
parentc6e8867396c7b8e24dc72b07cb565d4a4511b906 (diff)
downloadMrRoy-Overlay-672a43b6d8b0b8c30f224fc5895c87e0efec52bb.tar.gz
MrRoy-Overlay-672a43b6d8b0b8c30f224fc5895c87e0efec52bb.tar.bz2
MrRoy-Overlay-672a43b6d8b0b8c30f224fc5895c87e0efec52bb.zip
dev-python/emailthreads: new package, add 0.1.3
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/emailthreads/emailthreads-0.1.3.ebuild')
-rw-r--r--dev-python/emailthreads/emailthreads-0.1.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/emailthreads/emailthreads-0.1.3.ebuild b/dev-python/emailthreads/emailthreads-0.1.3.ebuild
new file mode 100644
index 0000000..02e597a
--- /dev/null
+++ b/dev-python/emailthreads/emailthreads-0.1.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Parses email threads into conversation trees"
+HOMEPAGE="https://github.com/emersion/python-emailthreads"
+SRC_URI="https://github.com/emersion/python-${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/python-${PN}-${PV}"
+
+distutils_enable_tests setup.py