aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-06-15 12:37:39 -0400
committerJulien Roy <julien@jroy.ca>2024-06-15 12:37:39 -0400
commitb4e2919f28ceeb72d318d1aa0602f70cb7378792 (patch)
treefb11e5f90d87663f94a39a780a38f515f135a326 /dev-python/django-simple-history/django-simple-history-3.7.0.ebuild
parenteff694ae800eb18d1387811ffaef69d3f7441bbe (diff)
downloadMrRoy-Overlay-b4e2919f28ceeb72d318d1aa0602f70cb7378792.tar.gz
MrRoy-Overlay-b4e2919f28ceeb72d318d1aa0602f70cb7378792.tar.bz2
MrRoy-Overlay-b4e2919f28ceeb72d318d1aa0602f70cb7378792.zip
dev-python/django-simple-history: add 3.7.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-simple-history/django-simple-history-3.7.0.ebuild')
-rw-r--r--dev-python/django-simple-history/django-simple-history-3.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild b/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild
new file mode 100644
index 0000000..59a6a00
--- /dev/null
+++ b/dev-python/django-simple-history/django-simple-history-3.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Store model history and view/revert changes from admin site"
+HOMEPAGE="
+ https://github.com/jazzband/django-simple-history
+ https://pypi.org/project/django-simple-history/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Tests fail to run
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/mysqlclient[${PYTHON_USEDEP}]
+
+ test? ( dev-python/asgiref[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py