aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-simple-history/django-simple-history-3.5.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-25 15:16:59 -0400
committerJulien Roy <julien@jroy.ca>2024-05-25 15:16:59 -0400
commit7b67040be725e52ea4b694b3b04fd770e3894d5f (patch)
treedcaaef3a47eabd320649d24b3dda396437d777d1 /dev-python/django-simple-history/django-simple-history-3.5.0.ebuild
parent2b5ba798893356463532e8864d5816e6707afc72 (diff)
downloadMrRoy-Overlay-7b67040be725e52ea4b694b3b04fd770e3894d5f.tar.gz
MrRoy-Overlay-7b67040be725e52ea4b694b3b04fd770e3894d5f.tar.bz2
MrRoy-Overlay-7b67040be725e52ea4b694b3b04fd770e3894d5f.zip
dev-python/django-simple-history: new package, add 3.5.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-simple-history/django-simple-history-3.5.0.ebuild')
-rw-r--r--dev-python/django-simple-history/django-simple-history-3.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/django-simple-history/django-simple-history-3.5.0.ebuild b/dev-python/django-simple-history/django-simple-history-3.5.0.ebuild
new file mode 100644
index 0000000..d1a19dc
--- /dev/null
+++ b/dev-python/django-simple-history/django-simple-history-3.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Store model history and view/revert changes from admin site"
+HOMEPAGE="
+ https://github.com/jazzband/django-simple-history
+ https://pypi.org/project/django-simple-history/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Tests fail to run
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/mysqlclient[${PYTHON_USEDEP}]
+
+ test? ( dev-python/asgiref[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py