aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-25 15:43:32 -0400
committerJulien Roy <julien@jroy.ca>2024-05-25 15:44:21 -0400
commit040e5fdd53890e2fb246f6f1df800bf1a5eefe02 (patch)
treef06a2ed2ec07edbe99631b0e77c71dba2fbbee80 /dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
parent541df308110ba7c99aabd3656d4f6fe027aded2a (diff)
downloadMrRoy-Overlay-040e5fdd53890e2fb246f6f1df800bf1a5eefe02.tar.gz
MrRoy-Overlay-040e5fdd53890e2fb246f6f1df800bf1a5eefe02.tar.bz2
MrRoy-Overlay-040e5fdd53890e2fb246f6f1df800bf1a5eefe02.zip
dev-python/django-recaptcha: new package, add 4.0.0
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild')
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild b/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
new file mode 100644
index 0000000..57deb06
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-4.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django reCAPTCHA form field/widget integration app"
+HOMEPAGE="
+ https://github.com/django-recaptcha/django-recaptcha
+ https://pypi.org/project/django-recaptcha/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# Can't get django tests to run
+RESTRICT="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest