aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-extensions/django-extensions-3.2.3.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-25 15:34:26 -0400
committerJulien Roy <julien@jroy.ca>2024-05-25 15:34:26 -0400
commit541df308110ba7c99aabd3656d4f6fe027aded2a (patch)
treef3503043ec9f8be9f3b45c95bd9c0080c18742e9 /dev-python/django-extensions/django-extensions-3.2.3.ebuild
parent10e3f9c4d52a5f543f5ba39e9f8a2e56b8d33cf6 (diff)
downloadMrRoy-Overlay-541df308110ba7c99aabd3656d4f6fe027aded2a.tar.gz
MrRoy-Overlay-541df308110ba7c99aabd3656d4f6fe027aded2a.tar.bz2
MrRoy-Overlay-541df308110ba7c99aabd3656d4f6fe027aded2a.zip
dev-python/django-extensions: new package, add 3.2.3
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/django-extensions/django-extensions-3.2.3.ebuild')
-rw-r--r--dev-python/django-extensions/django-extensions-3.2.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/django-extensions/django-extensions-3.2.3.ebuild b/dev-python/django-extensions/django-extensions-3.2.3.ebuild
new file mode 100644
index 0000000..5ea60cd
--- /dev/null
+++ b/dev-python/django-extensions/django-extensions-3.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extensions for the Django Framework"
+HOMEPAGE="
+ https://github.com/django-extensions/django-extensions
+ https://pypi.org/project/django-extensions/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Missing dependencies
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests setup.py