aboutsummaryrefslogtreecommitdiff
path: root/dev-python/core-srht/core-srht-0.69.7.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-03-01 20:10:11 -0500
committerJulien Roy <julien@jroy.ca>2023-03-01 20:10:11 -0500
commit30de2590a5a1e065587183d31c2cf239df6be36f (patch)
treeb435789a41bc7fa80ff06ad3f137329a1fe500b6 /dev-python/core-srht/core-srht-0.69.7.ebuild
parent480388d59e060e6becfc5b0040cdb027b305e51f (diff)
downloadMrRoy-Overlay-30de2590a5a1e065587183d31c2cf239df6be36f.tar.gz
MrRoy-Overlay-30de2590a5a1e065587183d31c2cf239df6be36f.tar.bz2
MrRoy-Overlay-30de2590a5a1e065587183d31c2cf239df6be36f.zip
dev-python/core-srht: drop 0.69.7
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/core-srht/core-srht-0.69.7.ebuild')
-rw-r--r--dev-python/core-srht/core-srht-0.69.7.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/core-srht/core-srht-0.69.7.ebuild b/dev-python/core-srht/core-srht-0.69.7.ebuild
deleted file mode 100644
index 923593b..0000000
--- a/dev-python/core-srht/core-srht-0.69.7.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-BOOTSTRAPVER="4.1.1"
-DESCRIPTION="sr.ht shared code"
-HOMEPAGE="https://git.sr.ht/~sircmpwn/core.sr.ht"
-SRC_URI="https://git.sr.ht/~sircmpwn/core.sr.ht/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/twbs/bootstrap/archive/v${BOOTSTRAPVER}.tar.gz -> bootstrap.tar.gz"
-S="${WORKDIR}/core.sr.ht-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/alembic[${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- dev-python/celery[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/humanize[${PYTHON_USEDEP}]
- dev-python/mistletoe[${PYTHON_USEDEP}]
- dev-python/PGPy[${PYTHON_USEDEP}]
- dev-python/prometheus_client[${PYTHON_USEDEP}]
- dev-python/psycopg:2[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/redis[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/SQLAlchemy-Utils[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="net-libs/nodejs"
-
-src_unpack() {
- default
- mv "${WORKDIR}/bootstrap-${BOOTSTRAPVER}" "${WORKDIR}/bootstrap" || die
- cp -r "${WORKDIR}/bootstrap" "${S}/srht/scss" || die
-}
-
-src_prepare() {
- distutils-r1_src_prepare
- pyver="$(python3 --version | cut -d. -f1-2 | cut -d' ' -f2-)"
- sed -e "s/python3.8/python$pyver/" -i srht/Makefile || die
-}
-
-src_compile() {
- export PKGVER=${PV}
- distutils-r1_src_compile
-}
-
-src_install() {
- export PKGVER=${PV}
- distutils-r1_src_install
-}