aboutsummaryrefslogtreecommitdiff
path: root/dev-python/core-srht/core-srht-0.69.7.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-01-03 16:31:41 -0500
committerJulien Roy <julien@jroy.ca>2023-01-03 16:31:41 -0500
commit2551dee893bddda09f19e277c5ec18862b44e4f4 (patch)
tree4da55b02f20d44d509e196d6026979a938d869fe /dev-python/core-srht/core-srht-0.69.7.ebuild
parent4f5805c335a8fa4e578088561f5e46ab651f2b14 (diff)
downloadMrRoy-Overlay-2551dee893bddda09f19e277c5ec18862b44e4f4.tar.gz
MrRoy-Overlay-2551dee893bddda09f19e277c5ec18862b44e4f4.tar.bz2
MrRoy-Overlay-2551dee893bddda09f19e277c5ec18862b44e4f4.zip
dev-python/python-srht: rename to core-srht, add 0.69.7, drop 0.65.8
Diffstat (limited to 'dev-python/core-srht/core-srht-0.69.7.ebuild')
-rw-r--r--dev-python/core-srht/core-srht-0.69.7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/core-srht/core-srht-0.69.7.ebuild b/dev-python/core-srht/core-srht-0.69.7.ebuild
new file mode 100644
index 0000000..a66701b
--- /dev/null
+++ b/dev-python/core-srht/core-srht-0.69.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+BOOTSTRAPVER="4.1.1"
+DESCRIPTION="sr.ht shared code"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/core.sr.ht"
+SRC_URI="https://git.sr.ht/~sircmpwn/core.sr.ht/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/twbs/bootstrap/archive/v${BOOTSTRAPVER}.tar.gz -> bootstrap.tar.gz"
+S="${WORKDIR}/core.sr.ht-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="network-sandbox"
+
+RDEPEND="dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/celery[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/mistletoe[${PYTHON_USEDEP}]
+ dev-python/PGPy[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/SQLAlchemy-Utils[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="net-libs/nodejs"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/bootstrap-${BOOTSTRAPVER}" "${WORKDIR}/bootstrap" || die
+ cp -r "${WORKDIR}/bootstrap" "${S}/srht/scss" || die
+}