aboutsummaryrefslogtreecommitdiff
path: root/dev-python/BTrees/BTrees-5.1.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-01-03 21:20:01 -0500
committerJulien Roy <julien@jroy.ca>2024-01-03 21:20:01 -0500
commitc9d2ef64fe9990d65a647e7ddd2fded44a3aff6c (patch)
treea00f503db7ddc6f8f50d9d3055e20c22119bf967 /dev-python/BTrees/BTrees-5.1.ebuild
parentd11e5f911af4f9678f38d40a9a24beb3015c300b (diff)
downloadMrRoy-Overlay-c9d2ef64fe9990d65a647e7ddd2fded44a3aff6c.tar.gz
MrRoy-Overlay-c9d2ef64fe9990d65a647e7ddd2fded44a3aff6c.tar.bz2
MrRoy-Overlay-c9d2ef64fe9990d65a647e7ddd2fded44a3aff6c.zip
moved from guru
Diffstat (limited to 'dev-python/BTrees/BTrees-5.1.ebuild')
-rw-r--r--dev-python/BTrees/BTrees-5.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/BTrees/BTrees-5.1.ebuild b/dev-python/BTrees/BTrees-5.1.ebuild
new file mode 100644
index 0000000..571aab9
--- /dev/null
+++ b/dev-python/BTrees/BTrees-5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="scalable persistent components"
+HOMEPAGE="https://github.com/zopefoundation/BTrees"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/persistent[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/persistent[${PYTHON_USEDEP}]
+ dev-python/transaction[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ zope-testrunner -pvc -j "$(nproc)" --usecompiled \
+ --path "${BUILD_DIR}/install$(python_get_sitedir)/" || die
+}