aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/rocclr/rocclr-4.5.0.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2021-12-10 09:30:26 -0500
committerJulien Roy <julien@jroy.ca>2021-12-10 09:30:26 -0500
commit925ffd2853388127af5af84a8679ff488f4a411f (patch)
tree7cc8ece79d195de5b011b1a0605aeba45873a12c /dev-libs/rocclr/rocclr-4.5.0.ebuild
parentb531093bc060027e06deb086f50ac7a1acaaefa2 (diff)
downloadMrRoy-Overlay-925ffd2853388127af5af84a8679ff488f4a411f.tar.gz
MrRoy-Overlay-925ffd2853388127af5af84a8679ff488f4a411f.tar.bz2
MrRoy-Overlay-925ffd2853388127af5af84a8679ff488f4a411f.zip
Added rocr-runtime-4.5.0/9999, rocclr-4.5.0/9999, rocm-comgr-4.5.0/9999, rocm-device-libs-4.5.0/9999
Diffstat (limited to 'dev-libs/rocclr/rocclr-4.5.0.ebuild')
-rw-r--r--dev-libs/rocclr/rocclr-4.5.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/rocclr/rocclr-4.5.0.ebuild b/dev-libs/rocclr/rocclr-4.5.0.ebuild
new file mode 100644
index 0000000..61430a3
--- /dev/null
+++ b/dev-libs/rocclr/rocclr-4.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ROCm-Developer-Tools/ROCclr"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/ROCm-Developer-Tools/ROCclr/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/archive/rocm-${PV}.tar.gz -> rocm-opencl-runtime-${PV}.tar.gz"
+ S="${WORKDIR}/ROCclr-rocm-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Common Language Runtime"
+HOMEPAGE="https://github.com/ROCm-Developer-Tools/ROCclr"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-libs/rocm-comgr:${SLOT}
+ dev-libs/rocr-runtime:${SLOT}"
+DEPEND="${RDEPEND}
+ virtual/opengl
+ dev-util/rocm-cmake:${SLOT}"
+
+PATCHES=(
+ "${FILESDIR}/rocclr-3.7.0-cmake-install-destination.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_COMGR_LIBRARY=YES
+ -DOPENCL_DIR="${WORKDIR}/ROCm-OpenCL-Runtime-rocm-${PV}"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ )
+ cmake_src_configure
+}
+