aboutsummaryrefslogtreecommitdiff
path: root/dev-libs/olm/olm-3.2.7.ebuild
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2021-12-10 22:55:52 -0500
committerJulien Roy <julien@jroy.ca>2021-12-10 22:55:52 -0500
commitb52d49edd6e5d18e26e7c721ca12c1b8452faa78 (patch)
tree917ed0a459b71961a95df34527aeb89d70f455ad /dev-libs/olm/olm-3.2.7.ebuild
parent1ff14feeeecaf6412c2a0bb3443ba863f3e86874 (diff)
downloadMrRoy-Overlay-b52d49edd6e5d18e26e7c721ca12c1b8452faa78.tar.gz
MrRoy-Overlay-b52d49edd6e5d18e26e7c721ca12c1b8452faa78.tar.bz2
MrRoy-Overlay-b52d49edd6e5d18e26e7c721ca12c1b8452faa78.zip
Added matrix olm 3.2.7
Diffstat (limited to 'dev-libs/olm/olm-3.2.7.ebuild')
-rw-r--r--dev-libs/olm/olm-3.2.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/olm/olm-3.2.7.ebuild b/dev-libs/olm/olm-3.2.7.ebuild
new file mode 100644
index 0000000..412091d
--- /dev/null
+++ b/dev-libs/olm/olm-3.2.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implementation of the olm and megolm cryptographic ratchets"
+HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm"
+SRC_URI="https://gitlab.matrix.org/matrix-org/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DOLM_TESTS="$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
+}
+
+src_install() {
+ use doc && DOCS=( README.md docs/{{,meg}olm,signing}.md )
+
+ cmake_src_install
+}