aboutsummaryrefslogtreecommitdiff
path: root/dev-python/flower/flower-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flower/flower-2.0.1.ebuild')
-rw-r--r--dev-python/flower/flower-2.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/flower/flower-2.0.1.ebuild b/dev-python/flower/flower-2.0.1.ebuild
new file mode 100644
index 0000000..2dac1a2
--- /dev/null
+++ b/dev-python/flower/flower-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Real-time monitor and web admin for Celery distributed task queue"
+HOMEPAGE="
+ https://github.com/mher/flower
+ https://pypi.org/project/flower/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/celery-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0.0[${PYTHON_USEDEP}]
+ <dev-python/tornado-7.0.0[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest