aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-compressor/django-compressor-4.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-compressor/django-compressor-4.5.1.ebuild')
-rw-r--r--dev-python/django-compressor/django-compressor-4.5.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/django-compressor/django-compressor-4.5.1.ebuild b/dev-python/django-compressor/django-compressor-4.5.1.ebuild
new file mode 100644
index 0000000..6cb1aec
--- /dev/null
+++ b/dev-python/django-compressor/django-compressor-4.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compresses linked and inline javascript or CSS into a single cached file"
+HOMEPAGE="
+ https://github.com/django-compressor/django-compressor
+ https://pypi.org/project/django-compressor/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Missing dependencies
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/django-appconf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs