aboutsummaryrefslogtreecommitdiff
path: root/dev-python/django-appconf/django-appconf-1.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-appconf/django-appconf-1.0.6.ebuild')
-rw-r--r--dev-python/django-appconf/django-appconf-1.0.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/django-appconf/django-appconf-1.0.6.ebuild b/dev-python/django-appconf/django-appconf-1.0.6.ebuild
new file mode 100644
index 0000000..f710eaf
--- /dev/null
+++ b/dev-python/django-appconf/django-appconf-1.0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An app to handle configuration defaults of packaged Django apps gracefully"
+HOMEPAGE="
+ https://github.com/django-compressor/django-appconf
+ https://pypi.org/project/django-appconf/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs