aboutsummaryrefslogtreecommitdiff
path: root/dev-python/asgiref/asgiref-3.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asgiref/asgiref-3.8.1.ebuild')
-rw-r--r--dev-python/asgiref/asgiref-3.8.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/asgiref/asgiref-3.8.1.ebuild b/dev-python/asgiref/asgiref-3.8.1.ebuild
new file mode 100644
index 0000000..630fe8b
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASGI specification and utilities "
+HOMEPAGE="
+ https://github.com/django/asgiref
+ https://pypi.org/project/asgiref
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest