aboutsummaryrefslogtreecommitdiff
path: root/net-misc/xmrig-mo/xmrig-mo-6.16.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/xmrig-mo/xmrig-mo-6.16.2.ebuild')
-rw-r--r--net-misc/xmrig-mo/xmrig-mo-6.16.2.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/net-misc/xmrig-mo/xmrig-mo-6.16.2.ebuild b/net-misc/xmrig-mo/xmrig-mo-6.16.2.ebuild
index 5912120..91f0718 100644
--- a/net-misc/xmrig-mo/xmrig-mo-6.16.2.ebuild
+++ b/net-misc/xmrig-mo/xmrig-mo-6.16.2.ebuild
@@ -13,8 +13,7 @@ SRC_URI="https://github.com/MoneroOcean/xmrig/archive/v${PV}-${MO_PV}.tar.gz ->
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+ssl"
-# TODO Add Donate USE flag
+IUSE="cuda donate opencl +ssl"
DEPEND="
dev-libs/libuv:=
@@ -36,12 +35,8 @@ src_configure() {
# TODO: Create expanded USE flag for all of the PoW algos.
-DWITH_TLS=$(usex ssl)
-
- # TODO: opencl USE flag.
- -DWITH_OPENCL=OFF
-
- # TODO: cuda USE flag.
- -DWITH_CUDA=OFF
+ -DWITH_OPENCL=$(usex opencl)
+ -DWITH_CUDA=$(usex cuda)
)
cmake_src_configure