aboutsummaryrefslogtreecommitdiff
path: root/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild')
-rw-r--r--net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild b/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild
deleted file mode 100644
index 0d47358..0000000
--- a/net-im/mautrix-telegram/mautrix-telegram-0.12.2_p20230118.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 optfeature systemd
-
-COMMIT="e655e0a8826eb66e3f133cfe6ab912d275a55715"
-DESCRIPTION="A Matrix-Telegram Messenger puppeting bridge "
-HOMEPAGE="https://github.com/mautrix/telegram/"
-SRC_URI="https://github.com/mautrix/telegram/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/telegram-${COMMIT}"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- acct-user/${PN}
- app-arch/brotli[python]
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/aiodns[${PYTHON_USEDEP}]
- dev-python/asyncpg[${PYTHON_USEDEP}]
- dev-python/commonmark[${PYTHON_USEDEP}]
- dev-python/cryptg[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/mautrix[${PYTHON_USEDEP}]
- dev-python/olm[${PYTHON_USEDEP}]
- dev-python/phonenumbers[${PYTHON_USEDEP}]
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/qrcode[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- ~dev-python/tulir-telethon-1.27.0_alpha6[${PYTHON_USEDEP}]
- dev-python/unpaddedbase64[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-src_install() {
- distutils-r1_src_install
-
- keepdir /var/log/mautrix
- fowners root:mautrix /var/log/mautrix
- fperms 770 /var/log/mautrix
- sed -i -e "s/\.\/${PN}.log/\/var\/log\/mautrix\/${PN}.log/" "${ED}/usr/example-config.yaml" || die
-
- insinto "/etc/mautrix"
- newins "${ED}/usr/example-config.yaml" "${PN/-/_}.yaml"
- rm "${ED}/usr/example-config.yaml" || die
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_newunit "${FILESDIR}/${PN}.unit" "${PN}.service"
-
- fowners -R root:mautrix /etc/mautrix
- fperms -R 770 /etc/mautrix
-}
-
-pkg_postinst() {
- optfeature "Prometheus statistics" dev-python/prometheus_client
- optfeature "Sqlite backend" dev-python/aiosqlite
-
- einfo
- elog ""
- elog "Before you can use ${PN}, you must configure it correctly"
- elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
- elog "When done, run the following command: emerge --config ${CATEGORY}/${PN}"
- elog "Then, you must register the bridge with your homeserver"
- elog "Refer your homeserver's documentation for instructions"
- elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
- elog "Finally, you may start the ${PN} daemon"
- einfo
-}
-
-pkg_config() {
- su - "${PN}" -s /bin/sh -c \
- "/usr/bin/python -m ${PN/-/_} -c /etc/mautrix/${PN/-/_}.yaml -g -r /var/lib/${PN/-/\/}/registration.yaml"
-}