aboutsummaryrefslogtreecommitdiff
path: root/gui-apps/tessen/tessen-2.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/tessen/tessen-2.1.2.ebuild')
-rw-r--r--gui-apps/tessen/tessen-2.1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gui-apps/tessen/tessen-2.1.2.ebuild b/gui-apps/tessen/tessen-2.1.2.ebuild
new file mode 100644
index 0000000..5299608
--- /dev/null
+++ b/gui-apps/tessen/tessen-2.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="an interactive menu to autotype and copy pass and gopass data"
+HOMEPAGE="https://github.com/ayushnix/tessen"
+SRC_URI="https://github.com/ayushnix/tessen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man +pass gopass dmenu bemenu wofi rofi fuzzel +wtype +clipboard notify otp xdg"
+
+REQUIRED_USE="|| ( pass gopass )
+ || ( dmenu bemenu wofi rofi fuzzel )"
+
+DEPEND="
+ man? ( app-text/scdoc )
+ app-shells/bash
+ dmenu? ( x11-misc/dmenu )
+ bemenu? ( dev-libs/bemenu )
+ wofi? ( gui-apps/wofi )
+ rofi? ( x11-apps/rofi )
+ fuzzel? ( gui-apps/fuzzel )
+ pass? ( app-admin/pass )
+ gopass? ( app-admin/gopass )
+ wtype? ( gui-apps/wtype )
+ clipboard? ( gui-apps/wl-clipboard )
+ notify? ( x11-libs/libnotify )
+ otp? ( app-admin/pass-otp )
+ xdg? ( x11-misc/xdg-utils )"
+RDEPEND="${DEPEND}"
+BDEPEND=""