aboutsummaryrefslogtreecommitdiff
path: root/gui-apps/grimblast/grimblast-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/grimblast/grimblast-9999.ebuild')
-rw-r--r--gui-apps/grimblast/grimblast-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gui-apps/grimblast/grimblast-9999.ebuild b/gui-apps/grimblast/grimblast-9999.ebuild
new file mode 100644
index 0000000..b2fdc7f
--- /dev/null
+++ b/gui-apps/grimblast/grimblast-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A helper for screenshots within hyprland"
+HOMEPAGE="https://github.com/hyprwm/contrib/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/contrib.git/"
+ inherit git-r3
+ S="${WORKDIR}/grimblast-9999/${PN}"
+else
+ SRC_URI="https://github.com/hyprwm/contrib/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/contrib-${COMMIT}/${PN}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-misc/jq
+ gui-apps/grim
+ gui-apps/slurp
+ gui-apps/wl-clipboard
+ gui-wm/hyprland
+ x11-libs/libnotify
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND=""
+
+src_install() {
+ dodoc grimblast.1
+ dobin grimblast
+}