aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-untrustedpython/zope-untrustedpython-5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-untrustedpython/zope-untrustedpython-5.0.ebuild')
-rw-r--r--dev-python/zope-untrustedpython/zope-untrustedpython-5.0.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/zope-untrustedpython/zope-untrustedpython-5.0.ebuild b/dev-python/zope-untrustedpython/zope-untrustedpython-5.0.ebuild
index 4a54cbc..87dce1f 100644
--- a/dev-python/zope-untrustedpython/zope-untrustedpython-5.0.ebuild
+++ b/dev-python/zope-untrustedpython/zope-untrustedpython-5.0.ebuild
@@ -16,17 +16,19 @@ S="${WORKDIR}/${PN/-/\.}-${PV}"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64"
-# Zope Testrunner
-RESTRICT="test"
RDEPEND="
dev-python/restrictedpython[${PYTHON_USEDEP}]
dev-python/zope-security[${PYTHON_USEDEP}]
+ test? (
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
"
DEPEND="${RDEPEND}"
distutils_enable_sphinx docs
-distutils_enable_tests unittest
+distutils_enable_tests setup.py
src_prepare() {
# strip rdep specific to namespaces
@@ -39,7 +41,8 @@ python_compile() {
find "${BUILD_DIR}" -name '*.pth' -delete || die
}
-src_test() {
- cd "${S}/src/zope/untrustedpython" || die
- distutils-r1_src_test
+python_test() {
+ distutils_write_namespace zope
+ zope-testrunner -pvc -j "$(nproc)" --usecompiled \
+ --path "${BUILD_DIR}/install$(python_get_sitedir)/zope" || die
}