aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-login/zope-login-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-login/zope-login-2.2.ebuild')
-rw-r--r--dev-python/zope-login/zope-login-2.2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/zope-login/zope-login-2.2.ebuild b/dev-python/zope-login/zope-login-2.2.ebuild
index 571ca2b..265a59a 100644
--- a/dev-python/zope-login/zope-login-2.2.ebuild
+++ b/dev-python/zope-login/zope-login-2.2.ebuild
@@ -16,8 +16,6 @@ S="${WORKDIR}/${PN/-/\.}-${PV}"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64"
-# Zope Testrunner
-RESTRICT="test"
RDEPEND="
dev-python/zope-authentication[${PYTHON_USEDEP}]
@@ -32,7 +30,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
distutils_enable_sphinx docs
-distutils_enable_tests unittest
+distutils_enable_tests setup.py
src_prepare() {
# strip rdep specific to namespaces
@@ -45,7 +43,8 @@ python_compile() {
find "${BUILD_DIR}" -name '*.pth' -delete || die
}
-src_test() {
- cd "${S}/src/zope/untrustedpython" || die
- distutils-r1_src_test
+python_test() {
+ distutils_write_namespace zope
+ zope-testrunner -pvc -j "$(nproc)" --usecompiled \
+ --path "${BUILD_DIR}/install$(python_get_sitedir)/zope" || die
}