aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-filerepresentation/zope-filerepresentation-6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-filerepresentation/zope-filerepresentation-6.0.ebuild')
-rw-r--r--dev-python/zope-filerepresentation/zope-filerepresentation-6.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/zope-filerepresentation/zope-filerepresentation-6.0.ebuild b/dev-python/zope-filerepresentation/zope-filerepresentation-6.0.ebuild
index 6dbb2ba..ebb0552 100644
--- a/dev-python/zope-filerepresentation/zope-filerepresentation-6.0.ebuild
+++ b/dev-python/zope-filerepresentation/zope-filerepresentation-6.0.ebuild
@@ -29,7 +29,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
distutils_enable_sphinx docs
-distutils_enable_tests unittest
+distutils_enable_tests setup.py
src_prepare() {
# strip rdep specific to namespaces
@@ -49,7 +49,8 @@ python_compile_all() {
rm "${BUILD_DIR}/install$(python_get_sitedir)/zope/__init__.py"
}
-src_test() {
- cd "${S}/src/zope/filerepresentation" || die
- distutils-r1_src_test
+python_test() {
+ distutils_write_namespace zope
+ zope-testrunner -pvc -j "$(nproc)" --usecompiled \
+ --path "${BUILD_DIR}/install$(python_get_sitedir)/zope" || die
}