aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-error/zope-error-4.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-error/zope-error-4.6.ebuild')
-rw-r--r--dev-python/zope-error/zope-error-4.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/zope-error/zope-error-4.6.ebuild b/dev-python/zope-error/zope-error-4.6.ebuild
new file mode 100644
index 0000000..f26d8e2
--- /dev/null
+++ b/dev-python/zope-error/zope-error-4.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An error reporting utility for Zope3"
+HOMEPAGE="https://github.com/zopefoundation/zope.error"
+SRC_URI="https://github.com/zopefoundation/zope.error/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+# Zope Testrunner
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/persistent[${PYTHON_USEDEP}]
+ dev-python/zope-exceptions[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-location[${PYTHON_USEDEP}]
+ test? (
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/untrustedpython" || die
+ distutils-r1_src_test
+}