aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-browser/zope-browser-2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-browser/zope-browser-2.4.ebuild')
-rw-r--r--dev-python/zope-browser/zope-browser-2.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/zope-browser/zope-browser-2.4.ebuild b/dev-python/zope-browser/zope-browser-2.4.ebuild
new file mode 100644
index 0000000..1baffca
--- /dev/null
+++ b/dev-python/zope-browser/zope-browser-2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Shared browser components for the Zope Toolkit"
+HOMEPAGE="https://github.com/zopefoundation/zope.browser"
+SRC_URI="https://github.com/zopefoundation/zope.browser/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ doc? (
+ $(python_gen_cond_dep 'dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}]' python3_{9..11})
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}