aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-authentication/zope-authentication-5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-authentication/zope-authentication-5.0.ebuild')
-rw-r--r--dev-python/zope-authentication/zope-authentication-5.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zope-authentication/zope-authentication-5.0.ebuild b/dev-python/zope-authentication/zope-authentication-5.0.ebuild
new file mode 100644
index 0000000..474299a
--- /dev/null
+++ b/dev-python/zope-authentication/zope-authentication-5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Definition of authentication basics for the Zope Framework"
+HOMEPAGE="https://github.com/zopefoundation/zope.authentication"
+SRC_URI="https://github.com/zopefoundation/zope.authentication/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN/-/\.}-${PV}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+# Zope Testrunner
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/zope-browser[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/zope-schema[${PYTHON_USEDEP}]
+ dev-python/zope-security[${PYTHON_USEDEP}]
+ doc? ( dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ cd "${S}/src/zope/untrustedpython" || die
+ distutils-r1_src_test
+}