aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zope-app-http/zope-app-http-5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-app-http/zope-app-http-5.0.ebuild')
-rw-r--r--dev-python/zope-app-http/zope-app-http-5.0.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/zope-app-http/zope-app-http-5.0.ebuild b/dev-python/zope-app-http/zope-app-http-5.0.ebuild
index c6a68b3..1751f45 100644
--- a/dev-python/zope-app-http/zope-app-http-5.0.ebuild
+++ b/dev-python/zope-app-http/zope-app-http-5.0.ebuild
@@ -16,8 +16,6 @@ S="${WORKDIR}/zope.app.http-${PV}"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64"
-# Zope Testrunner
-RESTRICT="test"
RDEPEND="
dev-python/zope-container[${PYTHON_USEDEP}]
@@ -38,7 +36,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-distutils_enable_tests unittest
+distutils_enable_tests setup.py
src_prepare() {
# strip rdep specific to namespaces
@@ -51,7 +49,8 @@ python_compile() {
find "${BUILD_DIR}" -name '*.pth' -delete || die
}
-src_test() {
- cd "${S}/src/zope/untrustedpython" || die
- distutils-r1_src_test
+python_test() {
+ distutils_write_namespace zope
+ zope-testrunner -pvc -j "$(nproc)" --usecompiled \
+ --path "${BUILD_DIR}/install$(python_get_sitedir)/zope/app" || die
}