aboutsummaryrefslogtreecommitdiff
path: root/dev-python/zodb/zodb-5.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zodb/zodb-5.8.0.ebuild')
-rw-r--r--dev-python/zodb/zodb-5.8.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/zodb/zodb-5.8.0.ebuild b/dev-python/zodb/zodb-5.8.0.ebuild
deleted file mode 100644
index d5a0b69..0000000
--- a/dev-python/zodb/zodb-5.8.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python object-oriented database"
-HOMEPAGE="https://github.com/zopefoundation/zodb"
-SRC_URI="https://github.com/zopefoundation/zodb/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/ZODB-${PV}"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/BTrees[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/persistent[${PYTHON_USEDEP}]
- dev-python/transaction[${PYTHON_USEDEP}]
- dev-python/zc-lockfile[${PYTHON_USEDEP}]
- dev-python/zconfig[${PYTHON_USEDEP}]
- dev-python/zodbpickle[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinxautozconfig[${PYTHON_USEDEP}]
- dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-zopeext[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/manuel[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/zope-testing[${PYTHON_USEDEP}]
- dev-python/zope-testrunner[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_sphinx docs
-distutils_enable_tests setup.py
-
-python_test() {
- zope-testrunner -pvc -j "$(nproc)" --usecompiled \
- --path "${BUILD_DIR}/install$(python_get_sitedir)/ZODB" || die
-}