aboutsummaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.4.2-r1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.4.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.4.2-r1.ebuild b/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.4.2-r1.ebuild
new file mode 100644
index 0000000..f65ba17
--- /dev/null
+++ b/dev-python/sphinxcontrib-zopeext/sphinxcontrib-zopeext-0.4.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm
+PYTHON_COMPAT=( python3_{10,11,12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension for using Zope interfaces"
+HOMEPAGE="https://github.com/sphinx-contrib/zopeext"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/pyproject.patch"
+)
+
+distutils_enable_tests pytest
+
+# Tests requires sphinx-testing which has been removed from ::gentoo
+RESTRICT="test"