aboutsummaryrefslogtreecommitdiff
path: root/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild')
-rw-r--r--dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild b/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild
new file mode 100644
index 0000000..77b944f
--- /dev/null
+++ b/dev-python/orderedmultidict/orderedmultidict-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Ordered Multivalue Dictionary. Helps power furl. "
+HOMEPAGE="https://github.com/gruns/orderedmultidict"
+SRC_URI="https://github.com/gruns/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="test? ( dev-python/flake8[${PYTHON_USEDEP}] )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest