aboutsummaryrefslogtreecommitdiff
path: root/dev-python/core-srht/core-srht-0.69.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/core-srht/core-srht-0.69.10.ebuild')
-rw-r--r--dev-python/core-srht/core-srht-0.69.10.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/core-srht/core-srht-0.69.10.ebuild b/dev-python/core-srht/core-srht-0.69.10.ebuild
new file mode 100644
index 0000000..72ade1a
--- /dev/null
+++ b/dev-python/core-srht/core-srht-0.69.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+BOOTSTRAPVER="4.1.1"
+DESCRIPTION="sr.ht shared code"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/core.sr.ht"
+SRC_URI="https://git.sr.ht/~sircmpwn/core.sr.ht/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/twbs/bootstrap/archive/v${BOOTSTRAPVER}.tar.gz -> bootstrap.tar.gz"
+S="${WORKDIR}/core.sr.ht-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/celery[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/mistletoe[${PYTHON_USEDEP}]
+ dev-python/PGPy[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/SQLAlchemy-Utils[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="net-libs/nodejs"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}/bootstrap-${BOOTSTRAPVER}" "${WORKDIR}/bootstrap" || die
+ cp -r "${WORKDIR}/bootstrap" "${S}/srht/scss" || die
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ pyver="$(python3 --version | cut -d. -f1-2 | cut -d' ' -f2-)"
+ sed -e "s/python3.8/python$pyver/" -i srht/Makefile || die
+}
+
+src_compile() {
+ export PKGVER=${PV}
+ distutils-r1_src_compile
+}
+
+src_install() {
+ export PKGVER=${PV}
+ distutils-r1_src_install
+}