aboutsummaryrefslogtreecommitdiff
path: root/dev-python/btrees/btrees-4.11.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/btrees/btrees-4.11.3.ebuild')
-rw-r--r--dev-python/btrees/btrees-4.11.3.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/btrees/btrees-4.11.3.ebuild b/dev-python/btrees/btrees-4.11.3.ebuild
deleted file mode 100644
index 44e5727..0000000
--- a/dev-python/btrees/btrees-4.11.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="scalable persistent components"
-HOMEPAGE="https://github.com/zopefoundation/BTrees"
-SRC_URI="https://github.com/zopefoundation/BTrees/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/BTrees-${PV}"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/persistent[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- doc? (
- dev-python/repoze-sphinx-autointerface[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/transaction[${PYTHON_USEDEP}]
- dev-python/zope-testrunner[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_sphinx docs
-distutils_enable_tests setup.py
-
-python_compile_all() {
- # Create Zope Namespace
- mkdir -p "${BUILD_DIR}/install$(python_get_sitedir)/zope" || die
- echo "__path__ = __import__('pkgutil').extend_path(__path__, __name__)" > \
- "${BUILD_DIR}/install$(python_get_sitedir)/zope/__init__.py" || die
- build_sphinx docs
- rm "${BUILD_DIR}/install$(python_get_sitedir)/zope/__init__.py"
-}
-
-python_test() {
- zope-testrunner -pvc -j "$(nproc)" --usecompiled \
- --path "${BUILD_DIR}/install$(python_get_sitedir)/BTrees" || die
-}