aboutsummaryrefslogtreecommitdiff
path: root/dev-python/PGPy/PGPy-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PGPy/PGPy-0.6.0.ebuild')
-rw-r--r--dev-python/PGPy/PGPy-0.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/PGPy/PGPy-0.6.0.ebuild b/dev-python/PGPy/PGPy-0.6.0.ebuild
new file mode 100644
index 0000000..597c92a
--- /dev/null
+++ b/dev-python/PGPy/PGPy-0.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Pretty Good Privacy for Python"
+HOMEPAGE="https://github.com/SecurityInnovation/PGPy
+ https://pypi.org/project/PGPy/"
+SRC_URI="https://github.com/SecurityInnovation/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="${RDEPEND}
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest