aboutsummaryrefslogtreecommitdiff
path: root/app-admin/tessen/tessen-2.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tessen/tessen-2.1.2.ebuild')
-rw-r--r--app-admin/tessen/tessen-2.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/tessen/tessen-2.1.2.ebuild b/app-admin/tessen/tessen-2.1.2.ebuild
new file mode 100644
index 0000000..07356f8
--- /dev/null
+++ b/app-admin/tessen/tessen-2.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="an interactive menu to autotype and copy pass and gopass data"
+HOMEPAGE="https://github.com/ayushnix/tessen"
+SRC_URI="https://github.com/ayushnix/tessen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man || ( +pass gopass ) || ( bemenu wofi rofi fuzzel ) +wtype +clipboard notify otp xdg"
+
+DEPEND="
+ man? ( app-text/scdoc )
+ app-shells/bash
+ bemenu? ( dev-libs/bemenu )
+ wofi? ( gui-apps/wofi )
+ rofi? ( x11-apps/rofi )
+ fuzzel? ( gui-apps/fuzzel )
+ pass? ( app-admin/pass )
+ gopass? ( app-admin/gopass )
+ wtype? ( gui-apps/wtype )
+ clipboard? ( gui-apps/wl-clipboard )
+ notify? ( x11-libs/libnotify )
+ otp? ( add-admin/pass-otp )
+ xdg? ( x11-misc/xdg-utils )
+ "
+RDEPEND="${DEPEND}"
+BDEPEND=""